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CHAPTER

ONE

GENERALITIES ABOUT CFDSTUDY

1.1 Introduction

The CFDSTUDY is a component for the SALOME platform. The purpose of this software is to pro-
vide an interface between CFD (Computational Fluid Dynamics) softwares Code_Saturne and NEP-
TUNE_CFD with other modules of the platform.

Code_Saturne and NEPTUNE_CFD are CFD softwares from EDF R&D. Code_Saturne could be freely
downloaded from http://code-saturne.org.

This document provides a tutorial for the use of CFDSTUDY with Code_Saturne. For a Code_Saturne
tutorial itself and more information about user issues, please consult the software documentation.

Note: CFDSTUDY is a pure Python module of SALOME. Only the GUI part of the module is imple-
mented without its engine counterpart. Therefore, the dump functionality is not available.

1.2 Reference functionalities

The main purpose of CFDSTUDY is to embed the GUI of Code_Saturne inside the SALOME desktop
and to make easier the setup of a case. For that, when the module is loaded, several hooks are available:

• Menubar

– File > CFD code menu:

* Save CFD Data file

* Save as CFD Data file

– CFDSTUDY menu:

* Set CFD study Location: allow to chose an existing study, or to create a new one.
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* Update Object Browser: refresh the directories list in the Object Browser.

* CFDSTUDY information: display information about the code.

* Tools: display the file of parameter, open an xterm.

– Help menu:

* CFDSTUDY module User’s guide menu: display this document in html format.

* Code_Saturne NEPTUNE_CFD menu: several guides are available through this
menu. These guides are enable only if the GUI of the code is displayed.

• Toolbar

– From the left to the right:

* Set CFD study Location

* Add a new case in a study

* Launch the GUI

* Run a case

* Save CFD Data file

* Save as CFD Data file

* Close a GUI

* Undo
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* Redo

• GUI: additional functionalities are available:

– Groups of boundary faces can be selected in the Object Browser or graphically,

– Groups of cells can be selected in the Object Browser or graphically,

– Monitoring points can be displayed in the VTK viewver.

• Object Browser: several actions are available through a specific contextual menu (open by Right
click)

– Study directory:

– Mesh file:

– Case directory:

– SaturneGUI file:

– File of parameters:
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– File of functions in the SRC directory:

– File of functions in the REFERENCE directory:

– File of functions in the DRAFT directory:

– Script of runcase file:

– Results directories in the RESU directory:
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CHAPTER

TWO

TUTORIALS

2.1 Code_Saturne tutorial: turbulent mixing in a T-junction

2.1.1 Introduction

This tutorial provides a complete course with Code_Saturne.

This tutorial is covering the following items:

• first, creation of the CAD design with the module Geometry

• then the meshing step with the module Mesh

• in order to do a CFD calculation, do a setup of Code_Saturne through the module CFDSTUDY

• at last, some elements for the post processing of the results with the module Paravis

The proposed case is on turbulent mixing between cold and hot water inside a pipe. The pipe is composed
with a T-junction and an elbow. This exercise is inspired from a more complex study of thermal fatigue
caused by the turbulent mixing of hot and cold flows just upstream of the elbow. Of course, the case is
very simplified here.
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2.1.2 Open SALOME

The command to open salome is ./code_saturne salome. For information about installation of
Code_Saturne with SALOME, please consult the installation guide of Code_Saturne.

2.1.3 CAD design with the module Geometry

The CAD model is built by extrusion of disks along paths (i.e. lines and wires). We need to define two
paths for the two tubes, and two disks which are faces built on circles. The two volumes obtained are
regrouped into one volume (fusion).

After the construction of the solid, we have to define the boundary conditions zones for the CFD
calculation: that is to say two inlet faces, the outlet face, and the internal wall of the tubes.

• Note: objects graphical manipulation in the 3D view (rotation, zoom, translation) can be done
with <Ctrl> + mouse buttons.

Activate the module Geometry.

Points, lines and wire

• Creation of points: open the Notebook: “File > Notebook” and add the following variables:
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Variable_Name Variable_Value
P1 -0.14
P2 0.1
P3 0.095
P4 0.171
P5 0.24
P6 0.076
radius 0.036

Select the menu “New Entity > Basic > Point” or click the toolbar button “Create a Point”. In
the dialog window for the creation of the points create the following entities:

Name X Y Z
Vertex_1 P1 0 0
Vertex_2 0 0 0
Vertex_3 P6 0 0
Vertex_4 0 P2 0
Vertex_5 P6 P3 0
Vertex_6 P4 P3 0
Vertex_7 P4 P5 0

The points are not visible without a zoom. After 3 or 4 new points, use the mouse wheel to zoom
in.
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• Creation of the lines: select the menu “New Entity > Basic > Line” (or click the equivalent
toolbar button). To define a line, select successively the begin and end point, either in Object
Browser or in the 3D view.

Three lines must be defined:

Name Point1 Point2
Line_1 Vertex_1 Vertex_3
Line_2 Vertex_2 Vertex_4
Line_3 Vertex_6 Vertex_7

• Creation of the arc (a 1/4 of circle): select the menu “New Entity > Basic > Arc” (or click the
equivalent toolbar button). Then, in the dialog window, select the second mode of creation (i.e.
with a center point, and two points).
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Then the arc must be defined:

Name Center Point Start Point End Point
Arc_1 Vertex_5 Vertex_3 Vertex_6

• Creation of the wire: select the menu “New Entity > Build > Wire”. To select together Line_1,
Arc_1 and Line_3, use <Ctrl> + left click in the Object Browser.

• Note: in order to create this wire, we could use also the menu “New Entity > Sketch”.
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Faces and pipes

• Creation of the two disks: open the dialog window with the menu “New Entity > Primitive >
Disk”. For each disk, in the dialog window, select the second mode of creation (i.e. with a center
point, a vector and a radius).

In the hierarchical geometric entities, these disks are faces.

Name Center Point Vector Radius
Disk_1 Vertex_1 Line_1 radius
Disk_2 Vertex_4 Line_2 radius
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• Creation of the two pipes: select the menu “New Entity > Generation > Extrusion Along a
Path”. In our case the two paths are respectively: Wire_1 and Line_2. In the hierarchical geomet-
ric entities, these pipes are solids.

Name Base Object Path Object
Pipe_1 Disk_1 Wire_1
Pipe_2 Disk_2 Line_2
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Fusion of the two pipes

• At that stage, we have build two separate solids. We must fuse these two solids into a single one.
In order to do this fusion, select the menu “Operations > Boolean > Fuse”. Then rename the
new object as Pipe (by default, is name is Fuse_1).

Name Object 1 Object 2
Pipe Pipe_1 Pipe_2
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• Use the menus “Measures > Check shape” and “Measures > What is” to verify the object Pipe.
It must be constituted of a single solid.

Groups for boundary conditions definition

Fisrt, choose the shading view mode instead of the wireframe view mode, in order to select faces in the
menu “View > Display Mode”.

In the Object Browser, select the Pipe object, use popup menus “Show only” and “Create group”.
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Select faces as shape type (3rd choice under Shape Type header: one can select Vertices, Edges, Faces
or Solids on a shape):

Give the name Inlet1 to the new group and highlight (right click in the 3D view) the face corresponding
to Inlet1 on the Pipe. Then, push button “Add” (the number below identifies the face into the main
shape), and apply. To be able to select a face, you may have to rotate the shape: <Ctrl> + right click.
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Proceed as above for the 3 other groups: Inlet2, Outlet and Wall. For faces selection of “Wall”, use the
<Shift> + left click to make a multiple selection: the wall is constituted with 4 faces.
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The CAD model (i.e. Pipe) is ready for meshing. Save your study (“File > Save” or <Ctrl> + S).

2.1.4 Meshing

In the scope of this tutorial, only the simplest way to mesh a CAD model is shown.

Activate the module Mesh.

Mesh with a layer of prisms on Wall

• Select the Pipe object in Object Browser, then select menu “Mesh > Create Mesh”.

• In “3D” tab, select option “(Tetrahedron) Netgen”.
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• Click on the only active button on “Add Hypothesis” line, and select “Viscous Layer”.

• Click on the only active button on “Add Hypothesis” line, and select “Viscous Layer”. Set the
“Total thickness” to 0.015 and the “Number of layers” to 3. Then add the Faces without layers:
select in the Object Browser the groups Inlet1, Inlet2 and Outlet in Geometry and click on the
Add button.

• In “2D” tab, select option “Netgen 1D-2D” (nothing to do in the other tabs 1D and 0D).

• Click on the only active button on “Hypothesis” line, and select “NETGEN 2D Parameters”.

• The “Max. size” and the “Min. size” correspond to the maximal and minimal edge length of the
tetrahedrons. Set the sizes to 0.025 and 0.012. The “Fineness” governs the curves meshing: set
fineness equal to “Very fine”, and finally select “Allow Quadrangles”.

• After accepting the dialogs, select the new mesh in the Object Browser Mesh_1, and compute it
by selecting the popup menu “Compute” or the toolbar button “Compute”.

• After a few seconds, the mesh is displayed, with an information dialog.
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• Note: for a full tetrahedrons mesh, in “3D” tab just select option “Netgen 1D-2D-3D” (nothing
to do in the other tabs), and fit hypothesis by clicking on the only active button on “Hypothesis”
line, and select “NETGEN 3D Parameters”.

Groups on the mesh for boundary conditions definition

The groups defined on the CAD model for the boundary condition zones must have their counterparts in
the mesh.

• Select the mesh Mesh_1 in Object Browser, rename the mesh as Pipe with the popup menu
“Rename”.

• With the mesh still selected, create groups from Geometry (popup menu “Create Groups from
Geometry”). In the Object Browser select the 4 groups defined on the CAD model. They appear
in the dialog window. Apply.
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• Display only the 3 groups corresponding to inlets and outlet:
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• Save the mesh in a MED file. Click left on mesh Pipe in Object Browser and select “Export to
MED File”, and use the name Pipe.med.

Warning: verify that all faces belong to a single group.

The mesh Pipe is ready for a CFD calculation. Save your study (“File > Save” or <Ctrl> + S).

2.1.5 CFD calculation with Code_Saturne

Activate the module CFDSTUDY.

Click on “New”. A dialog window displays information about Code_Saturne installation.
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If the installation of Code_Saturne is not found the following error message is displayed:

CFD study and case creation

By convention, CFD calculations with Code_Saturne are organized in studies and cases. Several calcu-
lations that share the same meshes and data sets, define a study for Code_Saturne. Each data set defined
in a case.

• Create a CFD study and a case by selecting the menu “CFDSTUDY > Set CFD study location”
(or the equivalent button in the toolbar).

• Use “Browse” button to select the directory which will contain the study directory. In our scope,
the study will be named PIPESTUDY, and the case CASE1.

The new study directory with the new case is created with its sub directories and files. Move the
mesh file Pipe.med in the directoty MESH of the sudy.

• The Object Browser reflects the study structure on the directory :
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Open the Code_Saturne GUI

• Open the Code_Saturne GUI by selecting CASE1 or SaturneGUI with the left mouse button in
Object Browser and click right on menu “Launch GUI”:

• Then a window dialog appear, click on “Activate”. The Code_Saturne GUI open itself in the
SALOME dekstop.

On the left dockWidget, the salome Object Browser and the navigation tree of the GUI are grouped on
tabs. When an item of the tree is selected, the corresponding panel raises in the GUI.
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Define the CFD calculation

Now we start to input data for the CFD calculation definition. In the scope of this tutorial, we do not
have to explore all the panels of the tree (from top to bottom), because lot of default values are adapted
to this case, so we just have to fill a few panels.

Location of the mesh file

Open “Meshes selection”. Use “Add” button to open a file dialog, and select the MED file previously
saved.

Mesh quality criteria

Open “Mesh quality criteria”. Verify that the “Post-processing format” is choosen to Ensight Gold.
Click on “Check mesh” button.

The GUI displays a listing with information about quality. Then, refresh the Object Browser with the
toolbar button “Updating Object browser”. There are new directories check_mesh/postprocessing in
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the RESU directory.

The file BOUNDARY_GROUPS.case and MESH_GROUPS.case contain information on groups loca-
tion. The file QUALITY.case contains quality criteria as fields. In order to visualize these quality criteria,
we have to open the Paravis module and open the QUALITY.case file from the postprocessing directory.

After exploring mesh quality criteria, re-activate the module CFDSTUDY in order to continue the data
input.

Thermophysical models

Open “Thermal model” and choose Tempreature (Celsius).

Fluid properties
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Open “Fluid properties”.

• Set reference values for water at 19 degrees Celsius:

– density: 998 kg/m3

– viscosity: 0.001 Pa.s

– Specific heat: 4181 J/kg/K

– thermal conductivity: 0.6 W/m/K

• User laws are imposed for density, viscosity and thermal conductivity. For density, viscosity
and thermal conductivity, select “user law”, and open the window dialog in order to give the
associated formula:

– density: rho = 1000.94843 - 0.049388484 * TempC -0.000415645022

* TempC^2;

– viscosity: mu = 0.0015452 - 3.2212e-5 * TempC + 2.45422e-7 *
TempC^2;

– thermal conductivity: lambda = 0.57423867 + 0.01443305 * TempC -
9.01853355e-7 * TempC^2;
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To take into account the effects of buoyancy, we have to impose a non-zero gravity.

Initialization

The initial temperature of the water in the pipe is set to 19 degrees.

Boundary conditions

Define locations graphically

• Open “Definition of boundary regions”.

Highlight successively each group of the mesh Pipe, by selecting the name of the group in the Object
Browser or by clicking the group in the VTK scene. When the group is highlighted, click on the “Add
from Salome” button.
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By default the nature of each new imported group is Wall. Double click in the cell of the nature in order
to edit it. In the same way, edit the label of the boundary condition zone.

Boundary conditions values

• Open “Boundary conditions”. For each inlet, give norm for the velocity, the hydraulic diameter
for the turbulence, and the prescribed value for the temperature, as shown on the figures below.
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Numerical parameters

Global parameters

• The default gradient calculation method is changed to Iterative method with Least Squares initial-
ization.

Equation parameters

• In order to save computation time, in the “Solver” tab, the precision is increase to 1.e-5 (select all
the concerned cells, and <Shift> + double right click to edit all cells in a single time).
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• In the “Scheme” tab, the convective scheme for the velocity is set to SOLU and for the turbulent
variables and the temperature is set to Upwind.

Time step

• In the “Time step” heading, set 0.0001 s for the time step. The number of iterations is set to 2000.

Calculation control

Writer In the “Output control” heading, tab “Writer”, define a frequency for the post-processing
output, in order to do temporal animation with results.
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Define monitoring points The purpose of the monitoring points is to record for each time step, the
value of selected variables. It allows to control stability and convergence of the calculation.

Number X Y Z
1 0.06 0.036 0
2 0.06 0 0.036
3 0.06 -0.036 0
4 0.06 0 -0.036
5 0.096 0.04 0
6 0.1 0.006 0.036
7 0.121 -0.028 0
8 0.1 0.006 -0.036
9 0.135 0.113 0
10 0.171 0.113 0.036
11 0.207 0.113 0
12 0.171 0.113 -0.036

The positions of the monitoring points are displayed on the SALOME view. The probes radius is set to
0.005 m.
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The format to be choosen (dat or csv) depends of the software which will plot the curves. For Paravis,
csv must be selected.

Calculation

Select “Prepare batch calculation” heading.

Before running Code_Saturne, save the case file (toolbar button or “File > Code_Saturne > Save as
data xml file” or <Shif> + <Ctrl> + S), with the name “tjunction.xml” (extension .xml could be om-
mited). It is possible to see the listing in real time, in order to do that in the “Advanced Options” the
option to listing must be replaced by to standard output.
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Click on Button “Code_Saturne batch running”. A popup window raises during the computation.
When the computation is completed, click on OK to close the window.

2.1.6 Post processing of results

In this section only the loading of the data in Paravis and the first steps are covered.

Activate the module Paravis, then load the RESULTS.case by clicking the menu File > Open ParaView
file. Click on the green button Apply. Now the data are loaded.

If more than a single mesh is present in the data (aka Part with the Ensight vocabulary), the filter Extract
Block should be apply; select: Filters > Alphabetical > Extract Block. Then, in the Propeties tab,
select the checkbox corresponding to the mesh to display, and click on the green button Apply.

It is possible to project cell data to the vertex; select Filters > Alphabetical > Cell Data to Point Data,
and click on the green button Apply.

Finally, select in the Display tab the variable to color the mesh.
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